schule-pong/flake.nix
2024-02-22 11:14:40 +01:00

60 lines
1.4 KiB
Nix

{
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
systems.url = "github:nix-systems/default";
devenv.url = "github:cachix/devenv";
fenix.url = "github:nix-community/fenix";
};
nixConfig = {
extra-trusted-public-keys = "devenv.cachix.org-1:w1cLUi8dv3hnoSPGAuibQv+f9TZLr6cv/Hm9XgU50cw=";
extra-substituters = "https://devenv.cachix.org";
};
outputs = {
self,
nixpkgs,
devenv,
systems,
...
} @ inputs: let
forEachSystem = nixpkgs.lib.genAttrs (import systems);
in {
devShells =
forEachSystem
(system: let
pkgs = nixpkgs.legacyPackages.${system};
in {
default = devenv.lib.mkShell {
inherit inputs pkgs;
modules = [
({
pkgs,
config,
...
}: {
languages.rust = {
enable = true;
channel = "nightly";
};
pre-commit.hooks = {
clippy.enable = true;
rustfmt.enable = true;
};
packages = with pkgs; [
xorg.libX11
pkg-config
bacon
libxkbcommon
xorg.libXi
xorg.libXcursor
cargo-watch
];
})
];
};
});
};
}