95 lines
2.9 KiB
Nix
95 lines
2.9 KiB
Nix
# Edit this configuration file to define what should be installed on
|
||
# your system. Help is available in the configuration.nix(5) man page
|
||
# and in the NixOS manual (accessible by running ‘nixos-help’).
|
||
|
||
{ config, pkgs, ... }:
|
||
|
||
{
|
||
imports =
|
||
[ # Include the results of the hardware scan.
|
||
./hardware-configuration.nix
|
||
./../common
|
||
];
|
||
# enable flakes
|
||
nix.settings.experimental-features = [ "nix-command" "flakes" ];
|
||
# Bootloader.
|
||
boot.loader.systemd-boot.enable = true;
|
||
boot.loader.efi.canTouchEfiVariables = true;
|
||
|
||
boot.initrd.luks.devices."luks-b568867f-1d41-4bc6-9639-12b5e23b90c0".device = "/dev/disk/by-uuid/b568867f-1d41-4bc6-9639-12b5e23b90c0";
|
||
networking.hostName = "twinkpad";
|
||
# Enable networking
|
||
networking.networkmanager.enable = true;
|
||
environment.pathsToLink = [ "/share/zsh" ];
|
||
environment.shells = [ "/home/polygon/.nix-profile/bin/zsh" ];
|
||
# Set your time zone.
|
||
|
||
# Enable the X11 windowing system.
|
||
services.xserver.enable = true;
|
||
|
||
# Enable the KDE Plasma Desktop Environment.
|
||
services.xserver.displayManager.sddm.enable = true;
|
||
services.xserver.desktopManager.plasma5.enable = true;
|
||
|
||
# Configure keymap in X11
|
||
services.xserver = {
|
||
layout = "de";
|
||
xkbVariant = "";
|
||
};
|
||
|
||
services.dbus.enable = true;
|
||
|
||
# Enable CUPS to print documents.
|
||
services.printing.enable = true;
|
||
|
||
|
||
# Define a user account. Don't forget to set a password with ‘passwd’.
|
||
users.users.polygon = {
|
||
isNormalUser = true;
|
||
description = "polygon-system";
|
||
extraGroups = [ "networkmanager" "wheel" ];
|
||
};
|
||
|
||
# Enable automatic login for the user.
|
||
services.xserver.displayManager.autoLogin.enable = true;
|
||
services.xserver.displayManager.autoLogin.user = "polygon";
|
||
|
||
# Allow unfree packages
|
||
nixpkgs.config.allowUnfree = true;
|
||
|
||
# List packages installed in system profile. To search, run:
|
||
# $ nix search wget
|
||
environment.systemPackages = with pkgs; [
|
||
neovim
|
||
wget
|
||
kitty
|
||
];
|
||
|
||
# Some programs need SUID wrappers, can be configured further or are
|
||
# started in user sessions.
|
||
# programs.mtr.enable = true;
|
||
# programs.gnupg.agent = {
|
||
# enable = true;
|
||
# enableSSHSupport = true;
|
||
# };
|
||
|
||
# List services that you want to enable:
|
||
|
||
# Enable the OpenSSH daemon.
|
||
# services.openssh.enable = true;
|
||
|
||
# Open ports in the firewall.
|
||
# networking.firewall.allowedTCPPorts = [ ... ];
|
||
# networking.firewall.allowedUDPPorts = [ ... ];
|
||
# Or disable the firewall altogether.
|
||
# networking.firewall.enable = false;
|
||
|
||
# This value determines the NixOS release from which the default
|
||
# settings for stateful data, like file locations and database versions
|
||
# on your system were taken. It‘s perfectly fine and recommended to leave
|
||
# this value at the release version of the first install of this system.
|
||
# Before changing this value read the documentation for this option
|
||
# (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
|
||
system.stateVersion = "23.11"; # Did you read the comment?
|
||
|
||
}
|